summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNalin Dahyabhai <nalin.dahyabhai@pobox.com>2008-07-01 11:36:16 -0400
committerNalin Dahyabhai <nalin.dahyabhai@pobox.com>2008-07-01 11:36:16 -0400
commit362fba5b3a5d3fe1c48dfc623ec3589a54f74a5d (patch)
treeb8756e963ec315fa4450f6120bf879fe1c6e3c74 /configure.ac
parentbb722d19687012a3af9734d7b2b196f3d09a820a (diff)
downloadslapi-nis-362fba5b3a5d3fe1c48dfc623ec3589a54f74a5d.tar.gz
slapi-nis-362fba5b3a5d3fe1c48dfc623ec3589a54f74a5d.tar.xz
slapi-nis-362fba5b3a5d3fe1c48dfc623ec3589a54f74a5d.zip
- change some parts of how the container configuration will be configured
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 14 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index ad5fc1e..0a3b24f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -143,22 +143,24 @@ AC_DEFINE_UNQUOTED(NIS_MAP_CONFIGURATION_SECURE_ATTR,"$secureattr",
[Define to name of the map configuration attribute which determines whether or not the map is treated a 'secure' map.])
AM_CONDITIONAL(SCHEMA,true)
-schbaseattr=schema-compat-base
-AC_DEFINE_UNQUOTED(SCH_CONTAINER_CONFIGURATION_BASE_ATTR,"$schbaseattr",
- [Define to name of the attribute which lists the containers to search when locating entries to be used for constructing entries for a given container.])
-schfilterattr=schema-compat-filter
-AC_DEFINE_UNQUOTED(SCH_CONTAINER_CONFIGURATION_FILTER_ATTR,"$schfilterattr",
- [Define to name of the attribute which holds the filter for selecting entries to be used for constructing entries for a given container.])
-schentryformatattr=schema-compat-entry-format
-AC_DEFINE_UNQUOTED(SCH_CONTAINER_CONFIGURATION_ENTRY_FORMAT_ATTR,
- "$schentryformatattr",
- [Define to name of the attribute which holds the format specifier used for constructing entries for a given container.])
groupattr=schema-compat-container-group
AC_DEFINE_UNQUOTED(SCH_CONTAINER_CONFIGURATION_GROUP_ATTR,"$groupattr",
[Define to name of the attribute which holds the name of the top-level container used for this set of compatibility containers.])
-containerattr=schema-compat-container-name
+containerattr=schema-compat-container-rdn
AC_DEFINE_UNQUOTED(SCH_CONTAINER_CONFIGURATION_CONTAINER_ATTR,"$containerattr",
- [Define to name of the attribute which holds the value for the compatibility container's RDN.])
+ [Define to name of the attribute which holds the compatibility container's RDN.])
+schbaseattr=schema-compat-search-base
+AC_DEFINE_UNQUOTED(SCH_CONTAINER_CONFIGURATION_BASE_ATTR,"$schbaseattr",
+ [Define to name of the attribute which lists the containers to search when locating entries to be used for constructing entries for a given container.])
+schfilterattr=schema-compat-search-filter
+AC_DEFINE_UNQUOTED(SCH_CONTAINER_CONFIGURATION_FILTER_ATTR,"$schfilterattr",
+ [Define to name of the attribute which holds the filter for selecting entries to be used for constructing entries for a given container.])
+rdnattr=schema-compat-entry-rdn
+AC_DEFINE_UNQUOTED(SCH_CONTAINER_CONFIGURATION_RDN_ATTR,"$rdnattr",
+ [Define to name of the attribute which is used to specify the RDN of a constructed entry.])
+attrattr=schema-compat-entry-attribute
+AC_DEFINE_UNQUOTED(SCH_CONTAINER_CONFIGURATION_ATTR_ATTR,"$attrattr",
+ [Define to name of the attribute which is used to specify attributes to be used when constructing entries.])
maxvalue_attr=nis-max-value-size
AC_DEFINE_UNQUOTED(NIS_PLUGIN_CONFIGURATION_MAXVALUE_ATTR,"$maxvalue_attr",