summaryrefslogtreecommitdiffstats
path: root/ipa-server/ipa-keytab-util/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ipa-server/ipa-keytab-util/Makefile.am')
-rw-r--r--ipa-server/ipa-keytab-util/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/ipa-server/ipa-keytab-util/Makefile.am b/ipa-server/ipa-keytab-util/Makefile.am
new file mode 100644
index 000000000..f0680e598
--- /dev/null
+++ b/ipa-server/ipa-keytab-util/Makefile.am
@@ -0,0 +1,22 @@
+NULL =
+
+sbin_PROGRAMS = \
+ ipa-keytab-util \
+ $(NULL)
+
+ipa_keytab_util_SOURCES = \
+ ipa-keytab-util.c \
+ $(NULL)
+
+ipa_keytab_util_LDADD = \
+ -lcap \
+ $(NULL)
+
+MAINTAINERCLEANFILES = \
+ *~ \
+ Makefile.in
+
+install-exec-hook:
+ -chown root:apache $(DESTDIR)$(sbindir)/ipa-keytab-util
+ -chmod o-rwxs $(DESTDIR)$(sbindir)/ipa-keytab-util
+ -chmod ug+s $(DESTDIR)$(sbindir)/ipa-keytab-util