summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJason Gerard DeRose <jderose@redhat.com>2008-10-21 19:46:07 -0600
committerJason Gerard DeRose <jderose@redhat.com>2008-10-21 19:46:07 -0600
commitd44afa0f1a19d5e71c5578eedefda2dccd6dc083 (patch)
treed2ba76a79dd4a457d02e745c6b601db366ac07d9 /setup.py
parentf8ffede3b9443bf92e529fe2be20454f52df10c9 (diff)
downloadfreeipa-d44afa0f1a19d5e71c5578eedefda2dccd6dc083.tar.gz
freeipa-d44afa0f1a19d5e71c5578eedefda2dccd6dc083.tar.xz
freeipa-d44afa0f1a19d5e71c5578eedefda2dccd6dc083.zip
Added a very basic setup.py using distutils
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py39
1 files changed, 39 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 000000000..feb4c9655
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,39 @@
+#!/usr/bin/python
+
+# Authors: Jason Gerard DeRose <jderose@redhat.com>
+#
+# Copyright (C) 2008 Red Hat
+# see file 'COPYING' for use and warranty information
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; version 2 only
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
+"""
+Python-level packaging using distutils.
+"""
+
+from distutils.core import setup
+
+setup(
+ name='freeipa',
+ version='1.99.0',
+ license='GNU GPL 2',
+ packages=[
+ 'ipalib',
+ 'ipalib.plugins',
+ 'ipa_server',
+ 'ipa_server.plugins',
+ 'ipa_webui',
+ ],
+ scripts=['ipa'],
+)