summaryrefslogtreecommitdiffstats
path: root/ipa-server/ipa-gui/setup.py
diff options
context:
space:
mode:
authorKarl MacMillan <kmacmill@redhat.com>2007-09-28 16:46:12 -0400
committerKarl MacMillan <kmacmill@redhat.com>2007-09-28 16:46:12 -0400
commit679343594d86d57c85d1a6bb5333c83ca8bacd78 (patch)
tree38bdfb23b5e561863c8c09f03abb9ee053a5ff92 /ipa-server/ipa-gui/setup.py
parent50d12d6d2e680d32a5940afa0242c2c75df57d1f (diff)
downloadfreeipa-679343594d86d57c85d1a6bb5333c83ca8bacd78.tar.gz
freeipa-679343594d86d57c85d1a6bb5333c83ca8bacd78.tar.xz
freeipa-679343594d86d57c85d1a6bb5333c83ca8bacd78.zip
Install the web gui
Install the turbogears web gui including an init script. This patch includes a few related changes: * create a production configuration * rename the web gui startup scrip to ipa-webgui * add an init script * chkconfig on the ipa-webgui init script * make the start script properly daemonize the app when not in a development directory. * Install everything to the correct places (/usr/sbin/ipa-webgui and /usr/share/ipa/ipagui mainly). There are some things still left to do: * Sort out the logging - the config needs to be adjusted so that logging messages end up in /var/log.
Diffstat (limited to 'ipa-server/ipa-gui/setup.py')
-rw-r--r--ipa-server/ipa-gui/setup.py20
1 files changed, 0 insertions, 20 deletions
diff --git a/ipa-server/ipa-gui/setup.py b/ipa-server/ipa-gui/setup.py
index 123817999..6b21712b4 100644
--- a/ipa-server/ipa-gui/setup.py
+++ b/ipa-server/ipa-gui/setup.py
@@ -19,30 +19,10 @@ setup(
install_requires = [
"TurboGears >= 1.0.2.2",
],
- scripts = ["start-ipagui.py"],
zip_safe=False,
packages=find_packages(),
package_data = find_package_data(where='ipagui',
package='ipagui'),
- keywords = [
- # Use keywords if you'll be adding your package to the
- # Python Cheeseshop
-
- # if this has widgets, uncomment the next line
- # 'turbogears.widgets',
-
- # if this has a tg-admin command, uncomment the next line
- # 'turbogears.command',
-
- # if this has identity providers, uncomment the next line
- # 'turbogears.identity.provider',
-
- # If this is a template plugin, uncomment the next line
- # 'python.templating.engines',
-
- # If this is a full application, uncomment the next line
- # 'turbogears.app',
- ],
classifiers = [
'Development Status :: 3 - Alpha',
'Operating System :: OS Independent',