summaryrefslogtreecommitdiffstats
path: root/ipa-server/Makefile.am
diff options
context:
space:
mode:
authorRob Crittenden <rcritten@redhat.com>2008-01-14 12:43:26 -0500
committerRob Crittenden <rcritten@redhat.com>2008-01-14 12:43:26 -0500
commitc7f3c746ccfd74480064dbe73fbc754548c30927 (patch)
treee0e8296dd50c0f9815f930713a2b3e917cb83bdf /ipa-server/Makefile.am
parent23ac773ada10867767e779823ab5f66c79b0dc04 (diff)
downloadfreeipa-c7f3c746ccfd74480064dbe73fbc754548c30927.tar.gz
freeipa-c7f3c746ccfd74480064dbe73fbc754548c30927.tar.xz
freeipa-c7f3c746ccfd74480064dbe73fbc754548c30927.zip
Backup system state in ipa-server-install
This patch adds a sysrestore module which allows ipa-server-install code to backup any system state so that it can be restored again with e.g. ipa-server-install --uninstall. The idea is that any files ipa-server-install modifies gets backed up to /var/cache/ipa/sysrestore/ while any "meta" state, like whether a service is enabled with chkconfig, is saved to /var/cache/ipa/sysrestore.state. Signed-off-by: Mark McLoughlin <markmc@redhat.com>
Diffstat (limited to 'ipa-server/Makefile.am')
-rw-r--r--ipa-server/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/ipa-server/Makefile.am b/ipa-server/Makefile.am
index a145ac031..b04a4cf98 100644
--- a/ipa-server/Makefile.am
+++ b/ipa-server/Makefile.am
@@ -13,6 +13,13 @@ SUBDIRS = \
xmlrpc-server \
$(NULL)
+install-exec-local:
+ mkdir -p $(DESTDIR)$(localstatedir)/cache/ipa/sysrestore
+
+uninstall-local:
+ -rmdir $(DESTDIR)$(localstatedir)/cache/ipa/sysrestore
+ -rmdir $(DESTDIR)$(localstatedir)/cache/ipa
+
EXTRA_DIST = \
ipa-server.spec \
COPYING \