summaryrefslogtreecommitdiffstats
path: root/ipa-python/setup.py
diff options
context:
space:
mode:
authorRob Crittenden <rcritten@redhat.com>2008-04-30 17:49:52 -0400
committerRob Crittenden <rcritten@redhat.com>2008-05-05 13:53:57 -0400
commit5ad2af3429580bc45bdfb7de53601ddf615266bf (patch)
tree546013e9f126d8d4d186421d1cf7450dfb8dda3b /ipa-python/setup.py
parent23fe67996cc05edf71d58bf52ef0aa8c7c0ecf7a (diff)
downloadfreeipa-5ad2af3429580bc45bdfb7de53601ddf615266bf.tar.gz
freeipa-5ad2af3429580bc45bdfb7de53601ddf615266bf.tar.xz
freeipa-5ad2af3429580bc45bdfb7de53601ddf615266bf.zip
Redo the way versioning works in freeIPA.
The file VERSION is now the sole-source of versioning. The generated .spec files will been removed in the maintainer-clean targets and have been removed from the repository. By default a GIT build is done. To do a non-GIT build do: $ make TARGET IPA_VERSION_IS_GIT_SNAPSHOT=no When updating the version you can run this to regenerate the version: $ make version-update The version can be determined in Python by using ipaserver.version.VERSION
Diffstat (limited to 'ipa-python/setup.py')
-rw-r--r--ipa-python/setup.py77
1 files changed, 0 insertions, 77 deletions
diff --git a/ipa-python/setup.py b/ipa-python/setup.py
deleted file mode 100644
index a48b8e690..000000000
--- a/ipa-python/setup.py
+++ /dev/null
@@ -1,77 +0,0 @@
-#!/usr/bin/env python
-# Copyright (C) 2007 Red Hat
-# see file 'COPYING' for use and warranty information
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License as
-# published by the Free Software Foundation; version 2 only
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-#
-
-"""FreeIPA python support library
-
-FreeIPA is a server for identity, policy, and audit.
-"""
-
-DOCLINES = __doc__.split("\n")
-
-import os
-import sys
-import distutils.sysconfig
-
-CLASSIFIERS = """\
-Development Status :: 4 - Beta
-Intended Audience :: System Environment/Base
-License :: GPL
-Programming Language :: Python
-Operating System :: POSIX
-Operating System :: Unix
-"""
-
-# BEFORE importing distutils, remove MANIFEST. distutils doesn't properly
-# update it when the contents of directories change.
-if os.path.exists('MANIFEST'): os.remove('MANIFEST')
-
-def setup_package():
-
- from distutils.core import setup
-
- old_path = os.getcwd()
- local_path = os.path.dirname(os.path.abspath(sys.argv[0]))
- os.chdir(local_path)
- sys.path.insert(0,local_path)
-
- try:
- setup(
- name = "ipa",
- version = "0.6.0",
- license = "GPL",
- author = "Karl MacMillan, et.al.",
- author_email = "kmacmill@redhat.com",
- maintainer = "freeIPA Developers",
- maintainer_email = "freeipa-devel@redhat.com",
- url = "http://www.freeipa.org/",
- description = DOCLINES[0],
- long_description = "\n".join(DOCLINES[2:]),
- download_url = "http://www.freeipa.org/page/Downloads",
- classifiers=filter(None, CLASSIFIERS.split('\n')),
- platforms = ["Linux", "Solaris", "Unix"],
- package_dir = {'ipa': ''},
- packages = [ "ipa" ],
- data_files = [('/etc/ipa', ['ipa.conf'])]
- )
- finally:
- del sys.path[0]
- os.chdir(old_path)
- return
-
-if __name__ == '__main__':
- setup_package()