summaryrefslogtreecommitdiffstats
path: root/ipa-client/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2010-11-04 17:08:26 +0100
committerSimo Sorce <ssorce@redhat.com>2010-11-22 16:01:35 -0500
commitce75d1c6d6595bcb26dbacf7393098a8f9accb3f (patch)
treeb5296adcad725d4b543fa566e906c2ed711054d9 /ipa-client/Makefile.am
parent5da451876e76fa8bfc04a537d30c2d3c5ef84841 (diff)
downloadfreeipa-ce75d1c6d6595bcb26dbacf7393098a8f9accb3f.tar.gz
freeipa-ce75d1c6d6595bcb26dbacf7393098a8f9accb3f.tar.xz
freeipa-ce75d1c6d6595bcb26dbacf7393098a8f9accb3f.zip
Stricter compilation flags
Use a little stricter compilation flags, in particular -Wall and treat implicit function declarations as errors. Signed-off-by: Simo Sorce <ssorce@redhat.com>
Diffstat (limited to 'ipa-client/Makefile.am')
-rw-r--r--ipa-client/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/ipa-client/Makefile.am b/ipa-client/Makefile.am
index 2fc45be25..655a68664 100644
--- a/ipa-client/Makefile.am
+++ b/ipa-client/Makefile.am
@@ -4,6 +4,14 @@ AUTOMAKE_OPTIONS = 1.7
NULL =
+AM_CFLAGS = $(NULL)
+if HAVE_GCC
+ AM_CFLAGS += -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith \
+ -Wcast-align -Werror-implicit-function-declaration \
+ $(NULL)
+endif
+export AM_CFLAGS
+
INCLUDES = \
-I. \
-I$(srcdir) \
@@ -13,6 +21,7 @@ INCLUDES = \
-DLIBEXECDIR=\""$(libexecdir)"\" \
-DDATADIR=\""$(datadir)"\" \
-DLOCALEDIR=\""$(localedir)"\" \
+ $(AM_CFLAGS) \
$(KRB5_CFLAGS) \
$(OPENLDAP_CFLAGS) \
$(MOZLDAP_CFLAGS) \