summaryrefslogtreecommitdiffstats
path: root/ipa-client/Makefile.am
diff options
context:
space:
mode:
authorRob Crittenden <rcritten@redhat.com>2009-12-04 16:29:09 -0500
committerRob Crittenden <rcritten@redhat.com>2009-12-04 16:29:09 -0500
commit62d40286ac67faa6b009e121035f92afa1372cf3 (patch)
tree1c9bfa065b4398aa529a65bd28ff5606858e626e /ipa-client/Makefile.am
parent8ecb5897c111b6243c5325dadf2af0e6cb1e4c33 (diff)
downloadfreeipa-62d40286ac67faa6b009e121035f92afa1372cf3.tar.gz
freeipa-62d40286ac67faa6b009e121035f92afa1372cf3.tar.xz
freeipa-62d40286ac67faa6b009e121035f92afa1372cf3.zip
A utility for removing principals from a keytab.
When we un-enroll a client we'll do a bit of cleanup including removing any principals for the IPA realm from /etc/krb5.keytab. This removes principals in 2 ways: - By principal, only entries matching the full principal are removed - By realm. Any principal for that realm is removed This does not change the KDC at all, just removes entries from a file on the client machine.
Diffstat (limited to 'ipa-client/Makefile.am')
-rw-r--r--ipa-client/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/ipa-client/Makefile.am b/ipa-client/Makefile.am
index 9a8b5f690..3f3c13b1a 100644
--- a/ipa-client/Makefile.am
+++ b/ipa-client/Makefile.am
@@ -22,6 +22,7 @@ INCLUDES = \
sbin_PROGRAMS = \
ipa-getkeytab \
+ ipa-rmkeytab \
ipa-join \
$(NULL)
@@ -37,6 +38,15 @@ ipa_getkeytab_LDADD = \
$(POPT_LIBS) \
$(NULL)
+ipa_rmkeytab_SOURCES = \
+ ipa-rmkeytab.c \
+ $(NULL)
+
+ipa_rmkeytab_LDADD = \
+ $(KRB5_LIBS) \
+ $(POPT_LIBS) \
+ $(NULL)
+
ipa_join_SOURCES = \
config.c \
ipa-join.c \