summaryrefslogtreecommitdiffstats
path: root/ipa-client/Makefile.am
diff options
context:
space:
mode:
authorSimo Sorce <simo@redhat.com>2014-11-17 15:19:57 -0500
committerSimo Sorce <simo@redhat.com>2014-11-20 10:52:13 -0500
commitb1a30bff04fe9763b8b270590ec37084fd19b4e0 (patch)
tree4e42782080c991d02e4c75a81ccec48228f013de /ipa-client/Makefile.am
parentc6afc489a1c9d86fd593bd47c4a8dae6d9a008d2 (diff)
downloadfreeipa-b1a30bff04fe9763b8b270590ec37084fd19b4e0.tar.gz
freeipa-b1a30bff04fe9763b8b270590ec37084fd19b4e0.tar.xz
freeipa-b1a30bff04fe9763b8b270590ec37084fd19b4e0.zip
Use asn1c helpers to encode/decode the getkeytab control
Replaces manual encoding with automatically generated code. Fixes: https://fedorahosted.org/freeipa/ticket/4718 https://fedorahosted.org/freeipa/ticket/4728 Reviewed-By: Alexander Bokovoy <abokovoy@redhat.com> Reviewed-By: Nathaniel McCallum <npmccallum@redhat.com>
Diffstat (limited to 'ipa-client/Makefile.am')
-rw-r--r--ipa-client/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/ipa-client/Makefile.am b/ipa-client/Makefile.am
index 2df175e53..b9c7020f3 100644
--- a/ipa-client/Makefile.am
+++ b/ipa-client/Makefile.am
@@ -14,11 +14,13 @@ export AM_CFLAGS
KRB5_UTIL_DIR=../util
KRB5_UTIL_SRCS=$(KRB5_UTIL_DIR)/ipa_krb5.c
+ASN1_UTIL_DIR=../asn1
AM_CPPFLAGS = \
-I. \
-I$(srcdir) \
-I$(KRB5_UTIL_DIR) \
+ -I$(ASN1_UTIL_DIR) \
-DPREFIX=\""$(prefix)"\" \
-DBINDIR=\""$(bindir)"\" \
-DLIBDIR=\""$(libdir)"\" \
@@ -45,6 +47,7 @@ ipa_getkeytab_SOURCES = \
$(NULL)
ipa_getkeytab_LDADD = \
+ ../asn1/libipaasn1.la \
$(KRB5_LIBS) \
$(OPENLDAP_LIBS) \
$(SASL_LIBS) \
@@ -80,6 +83,7 @@ ipa_join_LDADD = \
$(NULL)
SUBDIRS = \
+ ../asn1 \
ipaclient \
ipa-install \
man \