summaryrefslogtreecommitdiffstats
path: root/ipa-client/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2010-11-05 09:36:00 +0100
committerSimo Sorce <ssorce@redhat.com>2010-11-22 16:01:35 -0500
commit960fc6644714c1231a0822bc24b0750c873557df (patch)
tree4bc28ddd72920bc8d81a69a647a421be2800655a /ipa-client/Makefile.am
parent7086c9e8635a47966a7222e8efa30e873f0c1d95 (diff)
downloadfreeipa-960fc6644714c1231a0822bc24b0750c873557df.tar.gz
freeipa-960fc6644714c1231a0822bc24b0750c873557df.tar.xz
freeipa-960fc6644714c1231a0822bc24b0750c873557df.zip
ipa-client code cleanup
Fixes errors about implicit function declaration and moves duplicated gettext code into a common module. Also silences some warnings. Signed-off-by: Simo Sorce <ssorce@redhat.com>
Diffstat (limited to 'ipa-client/Makefile.am')
-rw-r--r--ipa-client/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/ipa-client/Makefile.am b/ipa-client/Makefile.am
index ebb9a8392..7d152fbfd 100644
--- a/ipa-client/Makefile.am
+++ b/ipa-client/Makefile.am
@@ -42,6 +42,7 @@ sbin_PROGRAMS = \
ipa_getkeytab_SOURCES = \
ipa-getkeytab.c \
+ ipa-client-common.c \
$(KRB5_UTIL_SRCS) \
$(NULL)
@@ -55,6 +56,7 @@ ipa_getkeytab_LDADD = \
ipa_rmkeytab_SOURCES = \
ipa-rmkeytab.c \
+ ipa-client-common.c \
$(NULL)
ipa_rmkeytab_LDADD = \
@@ -64,6 +66,7 @@ ipa_rmkeytab_LDADD = \
ipa_join_SOURCES = \
config.c \
+ ipa-client-common.c \
ipa-join.c \
$(NULL)