summaryrefslogtreecommitdiffstats
path: root/install/configure.ac
diff options
context:
space:
mode:
authorJohn Dennis <jdennis@redhat.com>2010-02-16 10:24:31 -0500
committerRob Crittenden <rcritten@redhat.com>2010-02-19 14:53:43 -0500
commite7dbbd96b4b0c63103fa2b1ba8f77da373ced6a8 (patch)
treee7d52e3a828560c1d0d86d8fc3ce4c7a6568fad4 /install/configure.ac
parent7ef9cc94ed08c208df09d7a08d68e14c5472bac9 (diff)
downloadfreeipa-e7dbbd96b4b0c63103fa2b1ba8f77da373ced6a8.tar.gz
freeipa-e7dbbd96b4b0c63103fa2b1ba8f77da373ced6a8.tar.xz
freeipa-e7dbbd96b4b0c63103fa2b1ba8f77da373ced6a8.zip
Add translation statistics
The Makefile in install/po has a new target "msg-stats" which prints out statistics concerning the current pot and po files. Here is an example: % make msg-stats ipa.pot has 133 messages id.po: 107/133 80.5% 13 po untranslated, 13 missing, 26 untranslated kn.po: 4/133 3.0% 116 po untranslated, 13 missing, 129 untranslated pl.po: 120/133 90.2% 0 po untranslated, 13 missing, 13 untranslated Also update configure.ac to search for msgcmp, awk & sed programs.
Diffstat (limited to 'install/configure.ac')
-rw-r--r--install/configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/install/configure.ac b/install/configure.ac
index 83579ac66..eb2d3cd13 100644
--- a/install/configure.ac
+++ b/install/configure.ac
@@ -20,6 +20,8 @@ AM_MAINTAINER_MODE
AC_SUBST(VERSION)
AC_PROG_MKDIR_P
+AC_PROG_AWK
+AC_PROG_SED
AC_PATH_PROG(XGETTEXT, xgettext, [no])
if test "x$XGETTEXT" = "xno"; then
@@ -41,6 +43,11 @@ if test "x$MSGMERGE" = "xno"; then
AC_MSG_ERROR([msgmerge not found, install gettext])
fi
+AC_PATH_PROG(MSGCMP, msgcmp, [no])
+if test "x$MSGCMP" = "xno"; then
+ AC_MSG_ERROR([msgcmp not found, install gettext])
+fi
+
AC_ARG_WITH([gettext_domain],
[AS_HELP_STRING([--with-gettext-domain=name],
[set the name of the i18n message catalog])],