summaryrefslogtreecommitdiffstats
path: root/install/configure.ac
diff options
context:
space:
mode:
authorJohn Dennis <jdennis@redhat.com>2011-08-17 18:27:45 -0400
committerMartin Kosek <mkosek@redhat.com>2011-08-18 14:26:10 +0200
commitc94ebfcb8469f477b93aab0baeccd30982910e82 (patch)
tree5d7b363b2439aa0c10a707d1c3800776c123701a /install/configure.ac
parent3d9ccdbedb15248644b20e19a6eb7e67366cac4a (diff)
downloadfreeipa-c94ebfcb8469f477b93aab0baeccd30982910e82.tar.gz
freeipa-c94ebfcb8469f477b93aab0baeccd30982910e82.tar.xz
freeipa-c94ebfcb8469f477b93aab0baeccd30982910e82.zip
ticket 1650 - compute accurate translation statistics
ticket 1650 (https://fedorahosted.org/freeipa/ticket/1650) has an extensive discussion of the issues, please refer to that. This patch does the following: * does not count fuzzy translations when computing translation statistics via the "msg-stats" make target in install/po * adds a new make target called "pull-po" which pulls updated po files from Transifex (configure.ac includes some trailing whitespace fixes) * turns off the generation of fuzzy translation suggestions during the message merge phase.
Diffstat (limited to 'install/configure.ac')
-rw-r--r--install/configure.ac10
1 files changed, 6 insertions, 4 deletions
diff --git a/install/configure.ac b/install/configure.ac
index 8a1dac635..f5ddab791 100644
--- a/install/configure.ac
+++ b/install/configure.ac
@@ -26,28 +26,30 @@ AC_PROG_SED
AC_PATH_PROG(XGETTEXT, xgettext, [no])
if test "x$XGETTEXT" = "xno"; then
AC_MSG_ERROR([xgettext not found, install gettext])
-fi
+fi
AC_PATH_PROG(MSGFMT, msgfmt, [no])
if test "x$MSGFMT" = "xno"; then
AC_MSG_ERROR([msgfmt not found, install gettext])
-fi
+fi
AC_PATH_PROG(MSGINIT, msginit, [no])
if test "x$MSGINIT" = "xno"; then
AC_MSG_ERROR([msginit not found, install gettext])
-fi
+fi
AC_PATH_PROG(MSGMERGE, msgmerge, [no])
if test "x$MSGMERGE" = "xno"; then
AC_MSG_ERROR([msgmerge not found, install gettext])
-fi
+fi
AC_PATH_PROG(MSGCMP, msgcmp, [no])
if test "x$MSGCMP" = "xno"; then
AC_MSG_ERROR([msgcmp not found, install gettext])
fi
+AC_PATH_PROG(TX, tx, [/usr/bin/tx])
+
AC_ARG_WITH([gettext_domain],
[AS_HELP_STRING([--with-gettext-domain=name],
[set the name of the i18n message catalog])],