summaryrefslogtreecommitdiffstats
path: root/install/configure.ac
diff options
context:
space:
mode:
authorJohn Dennis <jdennis@redhat.com>2010-02-09 13:14:25 -0500
committerRob Crittenden <rcritten@redhat.com>2010-02-09 22:07:18 -0500
commit4461a74403a3e931f5ca6f7a101ca66ff77d78e1 (patch)
tree86e03d45cae885a4484bf521a04c14826660aa4d /install/configure.ac
parent0ce253fae4916a81310172798cce4433a600a862 (diff)
downloadfreeipa-4461a74403a3e931f5ca6f7a101ca66ff77d78e1.tar.gz
freeipa-4461a74403a3e931f5ca6f7a101ca66ff77d78e1.tar.xz
freeipa-4461a74403a3e931f5ca6f7a101ca66ff77d78e1.zip
Add support for building internationalized translations.
A new directory install/po has been added which contains all the translations for all files in IPA. The build has been agumented to build these files. Also the autogen.sh script was mostly replaced by autoreconf, the preferred method. The old autogen.sh sript also had some serious bugs in the way it compared versions which caused it to run old versions of some of the tools, using standared autoreconf is much better.
Diffstat (limited to 'install/configure.ac')
-rw-r--r--install/configure.ac30
1 files changed, 30 insertions, 0 deletions
diff --git a/install/configure.ac b/install/configure.ac
index 826eeb047..83579ac66 100644
--- a/install/configure.ac
+++ b/install/configure.ac
@@ -19,6 +19,35 @@ AM_MAINTAINER_MODE
AC_SUBST(VERSION)
+AC_PROG_MKDIR_P
+
+AC_PATH_PROG(XGETTEXT, xgettext, [no])
+if test "x$XGETTEXT" = "xno"; then
+ AC_MSG_ERROR([xgettext not found, install gettext])
+fi
+
+AC_PATH_PROG(MSGFMT, msgfmt, [no])
+if test "x$MSGFMT" = "xno"; then
+ AC_MSG_ERROR([msgfmt not found, install gettext])
+fi
+
+AC_PATH_PROG(MSGINIT, msginit, [no])
+if test "x$MSGINIT" = "xno"; then
+ AC_MSG_ERROR([msginit not found, install gettext])
+fi
+
+AC_PATH_PROG(MSGMERGE, msgmerge, [no])
+if test "x$MSGMERGE" = "xno"; then
+ AC_MSG_ERROR([msgmerge not found, install gettext])
+fi
+
+AC_ARG_WITH([gettext_domain],
+ [AS_HELP_STRING([--with-gettext-domain=name],
+ [set the name of the i18n message catalog])],
+ [],
+ [with_gettext_domain=ipa])
+AC_SUBST(GETTEXT_DOMAIN, $with_gettext_domain)
+
dnl ---------------------------------------------------------------------------
dnl - Set the data install directory since we don't use pkgdatadir
dnl ---------------------------------------------------------------------------
@@ -39,6 +68,7 @@ AC_CONFIG_FILES([
tools/Makefile
tools/man/Makefile
updates/Makefile
+ po/Makefile
])
AC_OUTPUT