summaryrefslogtreecommitdiffstats
path: root/install/Makefile.am
diff options
context:
space:
mode:
authorMartin Kosek <mkosek@redhat.com>2012-06-08 08:31:37 +0200
committerRob Crittenden <rcritten@redhat.com>2012-06-10 21:23:10 -0400
commitc856fb60737612781fab30760bceeb8bbf6312d9 (patch)
treebea9c1f3240e876ac28eeb5db3eea2c5b9a036b3 /install/Makefile.am
parent4507dcda58bbe663597c43672f91af7225e2a9b4 (diff)
downloadfreeipa-c856fb60737612781fab30760bceeb8bbf6312d9.tar.gz
freeipa-c856fb60737612781fab30760bceeb8bbf6312d9.tar.xz
freeipa-c856fb60737612781fab30760bceeb8bbf6312d9.zip
Add sysupgrade state file
When IPA package is being updated, some of the configuration files are also updated. Sometimes it may be useful to store upgrade meta information for next package upgrades. For example an information that some config file was already updated and we don't want to update it again if user purposedly reverted the change. This patch adds a new StateFile in /var/lib/ipa/sysupgrade which is capable of holding this information. New sysupgrade.py module was created to provide simple API to access the upgrade state information.
Diffstat (limited to 'install/Makefile.am')
-rw-r--r--install/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/install/Makefile.am b/install/Makefile.am
index 4d24d072d..5670f9bd9 100644
--- a/install/Makefile.am
+++ b/install/Makefile.am
@@ -19,11 +19,14 @@ SUBDIRS = \
install-exec-local:
mkdir -p $(DESTDIR)$(localstatedir)/lib/ipa/sysrestore
chmod 700 $(DESTDIR)$(localstatedir)/lib/ipa/sysrestore
+ mkdir -p $(DESTDIR)$(localstatedir)/lib/ipa/sysupgrade
+ chmod 700 $(DESTDIR)$(localstatedir)/lib/ipa/sysupgrade
mkdir -p $(DESTDIR)$(localstatedir)/cache/ipa/sessions
chmod 700 $(DESTDIR)$(localstatedir)/cache/ipa/sessions
uninstall-local:
-rmdir $(DESTDIR)$(localstatedir)/lib/ipa/sysrestore
+ -rmdir $(DESTDIR)$(localstatedir)/lib/ipa/sysupgrade
-rmdir $(DESTDIR)$(localstatedir)/lib/ipa
-rmdir $(DESTDIR)$(localstatedir)/cache/ipa/sessions
-rmdir $(DESTDIR)$(localstatedir)/cache/ipa