summaryrefslogtreecommitdiffstats
path: root/daemons/ipa-slapi-plugins/ipa-lockout/Makefile.am
diff options
context:
space:
mode:
authorRob Crittenden <rcritten@redhat.com>2011-01-18 14:58:58 -0500
committerRob Crittenden <rcritten@redhat.com>2011-01-21 13:59:24 -0500
commitcf9ec1c4271e1f2b35f9a4377550064bad0387c3 (patch)
tree5f586544af7a8ca1f701d182d1584374b864d27b /daemons/ipa-slapi-plugins/ipa-lockout/Makefile.am
parent4361cd02422d8a6b30d67bb6869af9c67f7ec9c0 (diff)
downloadfreeipa-cf9ec1c4271e1f2b35f9a4377550064bad0387c3.tar.gz
freeipa-cf9ec1c4271e1f2b35f9a4377550064bad0387c3.tar.xz
freeipa-cf9ec1c4271e1f2b35f9a4377550064bad0387c3.zip
Update kerberos password policy values on LDAP binds.
On a failed bind this will update krbLoginFailedCount and krbLastFailedAuth and will potentially fail the bind altogether. On a successful bind it will zero krbLoginFailedCount and set krbLastSuccessfulAuth. This will also enforce locked-out accounts. See http://k5wiki.kerberos.org/wiki/Projects/Lockout for details on kerberos lockout. ticket 343
Diffstat (limited to 'daemons/ipa-slapi-plugins/ipa-lockout/Makefile.am')
-rw-r--r--daemons/ipa-slapi-plugins/ipa-lockout/Makefile.am46
1 files changed, 46 insertions, 0 deletions
diff --git a/daemons/ipa-slapi-plugins/ipa-lockout/Makefile.am b/daemons/ipa-slapi-plugins/ipa-lockout/Makefile.am
new file mode 100644
index 000000000..fea3fe67d
--- /dev/null
+++ b/daemons/ipa-slapi-plugins/ipa-lockout/Makefile.am
@@ -0,0 +1,46 @@
+NULL =
+
+PLUGIN_COMMON_DIR=../common
+
+INCLUDES = \
+ -I. \
+ -I$(srcdir) \
+ -I$(PLUGIN_COMMON_DIR) \
+ -I/usr/include/dirsrv \
+ -DPREFIX=\""$(prefix)"\" \
+ -DBINDIR=\""$(bindir)"\" \
+ -DLIBDIR=\""$(libdir)"\" \
+ -DLIBEXECDIR=\""$(libexecdir)"\" \
+ -DDATADIR=\""$(datadir)"\" \
+ $(AM_CFLAGS) \
+ $(LDAP_CFLAGS) \
+ $(WARN_CFLAGS) \
+ $(NULL)
+
+plugindir = $(libdir)/dirsrv/plugins
+plugin_LTLIBRARIES = \
+ libipa_lockout.la \
+ $(NULL)
+
+libipa_lockout_la_SOURCES = \
+ ipa_lockout.c \
+ $(NULL)
+
+libipa_lockout_la_LDFLAGS = -avoid-version
+
+libipa_lockout_la_LIBADD = \
+ $(LDAP_LIBS) \
+ $(NULL)
+
+appdir = $(IPA_DATA_DIR)
+app_DATA = \
+ lockout-conf.ldif \
+ $(NULL)
+
+EXTRA_DIST = \
+ $(app_DATA) \
+ $(NULL)
+
+MAINTAINERCLEANFILES = \
+ *~ \
+ Makefile.in