summaryrefslogtreecommitdiffstats
path: root/daemons/ipa-sam/Makefile.am
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2011-10-25 10:33:30 +0200
committerSimo Sorce <ssorce@redhat.com>2011-12-06 08:29:53 -0500
commitedb6ed5007e7b0b4ac118d567b94e04d996d8997 (patch)
treea4428fd03b1e983193567820e900cdf6541455bb /daemons/ipa-sam/Makefile.am
parent7c3e5f1be5cad9ee61547883ee1e4f852e14c3a7 (diff)
downloadfreeipa-edb6ed5007e7b0b4ac118d567b94e04d996d8997.tar.gz
freeipa-edb6ed5007e7b0b4ac118d567b94e04d996d8997.tar.xz
freeipa-edb6ed5007e7b0b4ac118d567b94e04d996d8997.zip
Add ipasam samba passdb backend
https://fedorahosted.org/freeipa/ticket/1874
Diffstat (limited to 'daemons/ipa-sam/Makefile.am')
-rw-r--r--daemons/ipa-sam/Makefile.am60
1 files changed, 60 insertions, 0 deletions
diff --git a/daemons/ipa-sam/Makefile.am b/daemons/ipa-sam/Makefile.am
new file mode 100644
index 000000000..002e34eca
--- /dev/null
+++ b/daemons/ipa-sam/Makefile.am
@@ -0,0 +1,60 @@
+NULL =
+SAMBA40EXTRA_LIBS = $(SAMBA40EXTRA_LIBPATH) \
+ -lsmbldap \
+ -lcliauth \
+ -lpdb \
+ -lsecurity \
+ -lutil_str \
+ -lsmbconf \
+ $(NULL)
+
+INCLUDES = \
+ -I. \
+ -I$(srcdir) \
+ -I/usr/include/samba-4.0 \
+ -DPREFIX=\""$(prefix)"\" \
+ -DBINDIR=\""$(bindir)"\" \
+ -DLIBDIR=\""$(libdir)"\" \
+ -DLIBEXECDIR=\""$(libexecdir)"\" \
+ -DDATADIR=\""$(datadir)"\" \
+ -DLDAPIDIR=\""$(localstatedir)/run"\" \
+ -DHAVE_LDAP \
+ $(AM_CFLAGS) \
+ $(LDAP_CFLAGS) \
+ $(KRB5_CFLAGS) \
+ $(WARN_CFLAGS) \
+ $(TALLOC_CFLAGS) \
+ $(SAMBAUTIL_CFLAGS) \
+ $(NDR_CFLAGS) \
+ $(NULL)
+
+plugindir = $(libdir)/samba/pdb
+plugin_LTLIBRARIES = \
+ ipasam.la \
+ $(NULL)
+
+ipasam_la_SOURCES = \
+ ipa_sam.c \
+ $(NULL)
+
+ipasam_la_LDFLAGS = \
+ -avoid-version \
+ -module \
+ $(NULL)
+
+ipasam_la_LIBADD = \
+ $(LDAP_LIBS) \
+ $(TALLOC_LIBS) \
+ $(SAMBAUTIL_LIBS) \
+ $(NDR_LIBS) \
+ $(SAMBA40EXTRA_LIBS) \
+ $(NULL)
+
+EXTRA_DIST = \
+ README \
+ ipa_sam.h \
+ $(NULL)
+
+MAINTAINERCLEANFILES = \
+ *~ \
+ Makefile.in