summaryrefslogtreecommitdiffstats
path: root/daemons/ipa-kdb/Makefile.am
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2013-02-19 12:16:37 +0100
committerMartin Kosek <mkosek@redhat.com>2013-03-08 10:46:00 +0100
commitefd4d80827a24794245327ce8b74b47e735f5b16 (patch)
tree556d6eb1e2c7d0b2b473c7f6b86f7e66681db654 /daemons/ipa-kdb/Makefile.am
parent4e3468211e37f71ca9d434512b68a4caddb2b314 (diff)
downloadfreeipa-efd4d80827a24794245327ce8b74b47e735f5b16.tar.gz
freeipa-efd4d80827a24794245327ce8b74b47e735f5b16.tar.xz
freeipa-efd4d80827a24794245327ce8b74b47e735f5b16.zip
Add unit test for get_authz_data_types()
https://fedorahosted.org/freeipa/ticket/2960
Diffstat (limited to 'daemons/ipa-kdb/Makefile.am')
-rw-r--r--daemons/ipa-kdb/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/daemons/ipa-kdb/Makefile.am b/daemons/ipa-kdb/Makefile.am
index 5f4e6e2a6..23ba1cc05 100644
--- a/daemons/ipa-kdb/Makefile.am
+++ b/daemons/ipa-kdb/Makefile.am
@@ -52,6 +52,35 @@ ipadb_la_LIBADD = \
$(NDRPAC_LIBS) \
$(NULL)
+if HAVE_CHECK
+TESTS = ipa_kdb_tests
+check_PROGRAMS = ipa_kdb_tests
+endif
+
+ipa_kdb_tests_SOURCES = \
+ tests/ipa_kdb_tests.c \
+ ipa_kdb.c \
+ ipa_kdb_common.c \
+ ipa_kdb_mkey.c \
+ ipa_kdb_passwords.c \
+ ipa_kdb_principals.c \
+ ipa_kdb_pwdpolicy.c \
+ ipa_kdb_mspac.c \
+ ipa_kdb_delegation.c \
+ ipa_kdb_audit_as.c \
+ $(KRB5_UTIL_SRCS) \
+ $(NULL)
+ipa_kdb_tests_CFLAGS = $(CHECK_CFLAGS)
+ipa_kdb_tests_LDADD = \
+ $(CHECK_LIBS) \
+ $(KRB5_LIBS) \
+ $(LDAP_LIBS) \
+ $(NDRPAC_LIBS) \
+ -lnss3 \
+ -lkdb5 \
+ -lsss_idmap \
+ $(NULL)
+
dist_noinst_DATA = ipa_kdb.exports
EXTRA_DIST = \