summaryrefslogtreecommitdiffstats
path: root/daemons/configure.ac
diff options
context:
space:
mode:
authorSimo Sorce <ssorce@redhat.com>2010-10-05 17:35:16 -0400
committerSimo Sorce <ssorce@redhat.com>2010-10-07 07:53:36 -0400
commitceb91a3f7175307e4fbae929e98063fba8cc9123 (patch)
tree844200c67552c814db05186a9eb5edb80c6ed57b /daemons/configure.ac
parent68604a79824a7acf7a3733bc9ccb7685da16e0e0 (diff)
downloadfreeipa-ceb91a3f7175307e4fbae929e98063fba8cc9123.tar.gz
freeipa-ceb91a3f7175307e4fbae929e98063fba8cc9123.tar.xz
freeipa-ceb91a3f7175307e4fbae929e98063fba8cc9123.zip
Always detect openldap and mozldap at the same time
Slapi plugins must use mozldap because 389 ds is compiled against that. ipa_kpasswd, instead, should be linked against openldap. So always make sure both are available.
Diffstat (limited to 'daemons/configure.ac')
-rw-r--r--daemons/configure.ac74
1 files changed, 32 insertions, 42 deletions
diff --git a/daemons/configure.ac b/daemons/configure.ac
index 65b79cb8a..7353c45a8 100644
--- a/daemons/configure.ac
+++ b/daemons/configure.ac
@@ -135,11 +135,9 @@ fi
AC_SUBST(KRB5_LIBS)
dnl ---------------------------------------------------------------------------
-dnl - Check for Mozilla LDAP or OpenLDAP SDK
+dnl - Check for Mozilla LDAP *and* OpenLDAP SDK
dnl ---------------------------------------------------------------------------
-AC_ARG_WITH(openldap, [ --with-openldap Use OpenLDAP])
-
dnl The mozldap libraries are always needed because ipa-slapi-plugins/dna/
dnl will not build against OpenLDAP.
SAVE_CPPFLAGS=$CPPFLAGS
@@ -160,47 +158,39 @@ if test "x$ac_cv_header_mozldap_ldap_h" = "xno" ; then
fi
PKG_CHECK_MODULES(MOZLDAP, mozldap > 6)
-if test x$with_openldap = xyes; then
- AC_CHECK_LIB(ldap, ldap_search, with_ldap=yes)
- dnl Check for other libraries we need to link with to get the main routines.
- test "$with_ldap" != "yes" && { AC_CHECK_LIB(ldap, ldap_open, [with_ldap=yes with_ldap_lber=yes], , -llber) }
- test "$with_ldap" != "yes" && { AC_CHECK_LIB(ldap, ldap_open, [with_ldap=yes with_ldap_lber=yes with_ldap_krb=yes], , -llber -lkrb) }
- test "$with_ldap" != "yes" && { AC_CHECK_LIB(ldap, ldap_open, [with_ldap=yes with_ldap_lber=yes with_ldap_krb=yes with_ldap_des=yes], , -llber -lkrb -ldes) }
- dnl Recently, we need -lber even though the main routines are elsewhere,
- dnl because otherwise be get link errors w.r.t. ber_pvt_opt_on. So just
- dnl check for that (it's a variable not a fun but that doesn't seem to
- dnl matter in these checks) and stick in -lber if so. Can't hurt (even to
- dnl stick it in always shouldn't hurt, I don't think) ... #### Someone who
- dnl #### understands LDAP needs to fix this properly.
- test "$with_ldap_lber" != "yes" && { AC_CHECK_LIB(lber, ber_pvt_opt_on, with_ldap_lber=yes) }
-
- if test "$with_ldap" = "yes"; then
- if test "$with_ldap_des" = "yes" ; then
- LDAP_LIBS="${LDAP_LIBS} -ldes"
- fi
- if test "$with_ldap_krb" = "yes" ; then
- LDAP_LIBS="${LDAP_LIBS} -lkrb"
- fi
- if test "$with_ldap_lber" = "yes" ; then
- LDAP_LIBS="${LDAP_LIBS} -llber"
- fi
- LDAP_LIBS="${LDAP_LIBS} -lldap"
- else
- AC_MSG_ERROR([OpenLDAP not found])
- fi
-
- AC_SUBST(LDAP_LIBS)
-
- LDAP_CFLAGS="${LDAP_CFLAGS} -DWITH_OPENLDAP"
- AC_SUBST(LDAP_CFLAGS)
+AC_CHECK_LIB(ldap, ldap_search, with_ldap=yes)
+dnl Check for other libraries we need to link with to get the main routines.
+test "$with_ldap" != "yes" && { AC_CHECK_LIB(ldap, ldap_open, [with_ldap=yes with_ldap_lber=yes], , -llber) }
+test "$with_ldap" != "yes" && { AC_CHECK_LIB(ldap, ldap_open, [with_ldap=yes with_ldap_lber=yes with_ldap_krb=yes], , -llber -lkrb) }
+test "$with_ldap" != "yes" && { AC_CHECK_LIB(ldap, ldap_open, [with_ldap=yes with_ldap_lber=yes with_ldap_krb=yes with_ldap_des=yes], , -llber -lkrb -ldes) }
+dnl Recently, we need -lber even though the main routines are elsewhere,
+dnl because otherwise be get link errors w.r.t. ber_pvt_opt_on. So just
+dnl check for that (it's a variable not a fun but that doesn't seem to
+dnl matter in these checks) and stick in -lber if so. Can't hurt (even to
+dnl stick it in always shouldn't hurt, I don't think) ... #### Someone who
+dnl #### understands LDAP needs to fix this properly.
+test "$with_ldap_lber" != "yes" && { AC_CHECK_LIB(lber, ber_pvt_opt_on, with_ldap_lber=yes) }
+
+if test "$with_ldap" = "yes"; then
+ if test "$with_ldap_des" = "yes" ; then
+ OPENLDAP_LIBS="${OPENLDAP_LIBS} -ldes"
+ fi
+ if test "$with_ldap_krb" = "yes" ; then
+ OPENLDAP_LIBS="${OPENLDAP_LIBS} -lkrb"
+ fi
+ if test "$with_ldap_lber" = "yes" ; then
+ OPENLDAP_LIBS="${OPENLDAP_LIBS} -llber"
+ fi
+ OPENLDAP_LIBS="${OPENLDAP_LIBS} -lldap"
else
- LDAP_LIBS="${MOZLDAP_LIBS}"
- AC_SUBST(LDAP_LIBS)
-
- LDAP_CFLAGS="${LDAP_CFLAGS} -DWITH_MOZLDAP"
- AC_SUBST(LDAP_CFLAGS)
+ AC_MSG_ERROR([OpenLDAP not found])
fi
+AC_SUBST(OPENLDAP_LIBS)
+
+OPENLDAP_CFLAGS="${OPENLDAP_CFLAGS} -DWITH_OPENLDAP"
+AC_SUBST(OPENLDAP_CFLAGS)
+
dnl ---------------------------------------------------------------------------
dnl - Check for OpenSSL Crypto library
dnl ---------------------------------------------------------------------------
@@ -310,7 +300,7 @@ echo "
source code location: ${srcdir}
compiler: ${CC}
cflags: ${CFLAGS}
- LDAP libs: ${LDAP_LIBS}
+ LDAP libs: ${OPENLDAP_LIBS}
KRB5 libs: ${KRB5_LIBS}
OpenSSL libs: ${SSL_LIBS}
Maintainer mode: ${USE_MAINTAINER_MODE}