summaryrefslogtreecommitdiffstats
path: root/daemons/configure.ac
diff options
context:
space:
mode:
authorRob Crittenden <rcritten@redhat.com>2010-10-26 15:14:05 -0400
committerRob Crittenden <rcritten@redhat.com>2010-10-26 15:39:43 -0400
commit9afedcb68315db2429656db0c89da47a669519e0 (patch)
tree5e6ce2ecda6651e33e55c56567310578f21828d1 /daemons/configure.ac
parent6abc4186b4f304e11bb6049d28e62f4abba92bc9 (diff)
downloadfreeipa-9afedcb68315db2429656db0c89da47a669519e0.tar.gz
freeipa-9afedcb68315db2429656db0c89da47a669519e0.tar.xz
freeipa-9afedcb68315db2429656db0c89da47a669519e0.zip
Error out when configure finds missing dependencies
ticket 315
Diffstat (limited to 'daemons/configure.ac')
-rw-r--r--daemons/configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/daemons/configure.ac b/daemons/configure.ac
index fe59da61c..53240469f 100644
--- a/daemons/configure.ac
+++ b/daemons/configure.ac
@@ -77,7 +77,7 @@ dnl - Check for KRB5
dnl ---------------------------------------------------------------------------
KRB5_LIBS=
-AC_CHECK_HEADER(krb5.h)
+AC_CHECK_HEADER(krb5.h, [], [AC_MSG_ERROR([krb5.h not found])])
krb5_impl=mit
@@ -197,6 +197,7 @@ dnl ---------------------------------------------------------------------------
dnl This is a very simple check, we should probably check also for MD4_Init and
dnl probably also the version we are using is recent enough
SSL_LIBS=
+AC_CHECK_HEADER(openssl/des.h, [], [AC_MSG_ERROR([openssl/des.h not found])])
AC_CHECK_LIB(crypto, DES_set_key_unchecked, [SSL_LIBS="-lcrypto"])
AC_SUBST(SSL_LIBS)