summaryrefslogtreecommitdiffstats
path: root/daemons/configure.ac
diff options
context:
space:
mode:
authorSimo Sorce <ssorce@redhat.com>2010-11-10 17:04:53 -0500
committerSimo Sorce <ssorce@redhat.com>2010-11-15 11:47:27 -0500
commit23f03251e06ea6795376f5a7bac0db3e6796a46b (patch)
tree35a2ff884ceeeb37e322fd06a61c694d13e443af /daemons/configure.ac
parentedf0f9b90188b0f55ce4a26351b7c356a7ae7086 (diff)
downloadfreeipa-23f03251e06ea6795376f5a7bac0db3e6796a46b.tar.gz
freeipa-23f03251e06ea6795376f5a7bac0db3e6796a46b.tar.xz
freeipa-23f03251e06ea6795376f5a7bac0db3e6796a46b.zip
uuid plugin: convert the plugin to use the libuuid library
The DS guys decided not to expose the DS inetrnal functions used to generate UUIDs for DS. This means the interface is not guaranteed to be available. Switch the ipa_uuid plugin to use the system libuuid plugin instead. NOTE: This causes once again a change in the tring format used for UUIDs. fixes: https://fedorahosted.org/freeipa/ticket/465
Diffstat (limited to 'daemons/configure.ac')
-rw-r--r--daemons/configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/daemons/configure.ac b/daemons/configure.ac
index b7ad33fed..53806f52d 100644
--- a/daemons/configure.ac
+++ b/daemons/configure.ac
@@ -202,6 +202,14 @@ AC_CHECK_LIB(crypto, DES_set_key_unchecked, [SSL_LIBS="-lcrypto"])
AC_SUBST(SSL_LIBS)
dnl ---------------------------------------------------------------------------
+dnl - Check for UUID library
+dnl ---------------------------------------------------------------------------
+AC_CHECK_HEADERS(uuid/uuid.h,,[AC_MSG_ERROR([uuid/uuid.h not found])])
+
+AC_CHECK_LIB(uuid, uuid_generate_time, [UUID_LIBS="-luuid"])
+AC_SUBST(UUID_LIBS)
+
+dnl ---------------------------------------------------------------------------
dnl - Check for Python
dnl ---------------------------------------------------------------------------