summaryrefslogtreecommitdiffstats
path: root/daemons/configure.ac
diff options
context:
space:
mode:
authorAlexander Bokovoy <abokovoy@redhat.com>2013-03-22 17:30:41 +0200
committerMartin Kosek <mkosek@redhat.com>2013-03-29 13:45:50 +0100
commitcc56723151c9ebf58d891e85617319d861af14a4 (patch)
treefef05ac70a3f2ecb26f5ed6664107c0c884adc61 /daemons/configure.ac
parent57d5042d28b107bbee757e825c077c5501face02 (diff)
downloadfreeipa-cc56723151c9ebf58d891e85617319d861af14a4.tar.gz
freeipa-cc56723151c9ebf58d891e85617319d861af14a4.tar.xz
freeipa-cc56723151c9ebf58d891e85617319d861af14a4.zip
ipasam: add enumeration of UPN suffixes based on the realm domains
PASSDB API in Samba adds support for specifying UPN suffixes. The change in ipasam will allow to pass through list of realm domains as UPN suffixes so that Active Directory domain controller will be able to recognize non-primary UPN suffixes as belonging to IPA and properly find our KDC for cross-realm TGT. Since Samba already returns primary DNS domain separately, filter it out from list of UPN suffixes. Also enclose provider of UPN suffixes into #ifdef to support both Samba with and without pdb_enum_upn_suffixes(). Part of https://fedorahosted.org/freeipa/ticket/2848
Diffstat (limited to 'daemons/configure.ac')
-rw-r--r--daemons/configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/daemons/configure.ac b/daemons/configure.ac
index 2f6a3e787..3e8e81f5e 100644
--- a/daemons/configure.ac
+++ b/daemons/configure.ac
@@ -252,6 +252,16 @@ AC_CHECK_LIB([wbclient],
[$SAMBA40EXTRA_LIBPATH])
AC_SUBST(WBCLIENT_LIBS)
+AC_CHECK_LIB([pdb],
+ [make_pdb_method],
+ [HAVE_LIBPDB=1],
+ [AC_MSG_ERROR([libpdb does not have make_pdb_method])],
+ [$SAMBA40EXTRA_LIBPATH])
+AC_CHECK_LIB([pdb],[pdb_enum_upn_suffixes],
+ [AC_DEFINE([HAVE_PDB_ENUM_UPN_SUFFIXES], [1], [Ability to enumerate UPN suffixes])],
+ [AC_MSG_WARN([libpdb does not have pdb_enum_upn_suffixes, no support for realm domains in ipasam])],
+ [$SAMBA40EXTRA_LIBPATH])
+
dnl ---------------------------------------------------------------------------
dnl - Check for check unit test framework http://check.sourceforge.net/
dnl ---------------------------------------------------------------------------