summaryrefslogtreecommitdiffstats
path: root/daemons/configure.ac
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2011-11-30 13:29:10 +0100
committerMartin Kosek <mkosek@redhat.com>2012-06-28 13:08:26 +0200
commit316aac5a8d03587872883a645ba6ff8443f062fe (patch)
tree33849455024f4c09868859d86ecf09d7822bfab2 /daemons/configure.ac
parentac6afd31f72d95bc23cde2b22a5fec8267147914 (diff)
downloadfreeipa-316aac5a8d03587872883a645ba6ff8443f062fe.tar.gz
freeipa-316aac5a8d03587872883a645ba6ff8443f062fe.tar.xz
freeipa-316aac5a8d03587872883a645ba6ff8443f062fe.zip
Add external domain extop DS plugin
This extop can be used by clients of the IPA domain, e.g. sssd, to retrieve data from trusted external domains. It can be used e.g. to map Windows SIDs to user or groups names and back.
Diffstat (limited to 'daemons/configure.ac')
-rw-r--r--daemons/configure.ac19
1 files changed, 18 insertions, 1 deletions
diff --git a/daemons/configure.ac b/daemons/configure.ac
index 9ee77e471..76ebaa67f 100644
--- a/daemons/configure.ac
+++ b/daemons/configure.ac
@@ -237,8 +237,19 @@ PKG_CHECK_MODULES([NDRPAC], [ndr_krb5pac])
PKG_CHECK_MODULES([NDRNBT], [ndr_nbt])
PKG_CHECK_MODULES([NDR], [ndr])
PKG_CHECK_MODULES([SAMBAUTIL], [samba-util])
-SAMBA40EXTRA_LIBPATH="-L`$PKG_CONFIG --variable=libdir samba-util`/samba"
+SAMBA40EXTRA_LIBPATH="-L`$PKG_CONFIG --variable=libdir samba-util`/samba -Wl,-rpath=`$PKG_CONFIG --variable=libdir samba-util`/samba"
AC_SUBST(SAMBA40EXTRA_LIBPATH)
+AC_CHECK_HEADERS([samba-4.0/wbclient.h],
+ ,
+ [AC_MSG_ERROR([samba-4.0/wbclient.h not found])],
+ [#include <stdbool.h>
+ #include <stdint.h>])
+AC_CHECK_LIB([wbclient],
+ [wbcLookupSid],
+ [WBCLIENT_LIBS="$SAMBA40EXTRA_LIBPATH -lwbclient"],
+ [AC_MSG_ERROR([libwbclient does not have wbcLookupSid])],
+ [$SAMBA40EXTRA_LIBPATH])
+AC_SUBST(WBCLIENT_LIBS)
dnl ---------------------------------------------------------------------------
dnl - Check for check unit test framework http://check.sourceforge.net/
@@ -251,6 +262,11 @@ else
fi
AM_CONDITIONAL([HAVE_CHECK], [test x$have_check != x])
+dnl -- dirsrv is needed for the extdom unit tests --
+PKG_CHECK_MODULES([DIRSRV], [dirsrv])
+dnl -- sss_idmap is needed by the extdom exop --
+PKG_CHECK_MODULES([SSSIDMAP], [sss_idmap])
+
dnl ---------------------------------------------------------------------------
dnl - Set the data install directory since we don't use pkgdatadir
dnl ---------------------------------------------------------------------------
@@ -320,6 +336,7 @@ AC_CONFIG_FILES([
ipa-slapi-plugins/ipa-enrollment/Makefile
ipa-slapi-plugins/ipa-lockout/Makefile
ipa-slapi-plugins/ipa-pwd-extop/Makefile
+ ipa-slapi-plugins/ipa-extdom-extop/Makefile
ipa-slapi-plugins/ipa-winsync/Makefile
ipa-slapi-plugins/ipa-version/Makefile
ipa-slapi-plugins/ipa-uuid/Makefile