summaryrefslogtreecommitdiffstats
path: root/daemons/configure.ac
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2013-07-03 14:27:14 +0200
committerAlexander Bokovoy <abokovoy@redhat.com>2013-07-11 12:39:27 +0300
commit18c5e483db719442de2965754ce912d0e4a02f61 (patch)
tree89c02721f1d09774ebfcd2d96345edeedd1a11d5 /daemons/configure.ac
parentcf97590e979b680ee34ecbdb504d601ad45fb50a (diff)
downloadfreeipa-18c5e483db719442de2965754ce912d0e4a02f61.tar.gz
freeipa-18c5e483db719442de2965754ce912d0e4a02f61.tar.xz
freeipa-18c5e483db719442de2965754ce912d0e4a02f61.zip
extdom: replace winbind calls with POSIX/SSSD calls
With the new ipa_server_mode SSSD is able to read user and group data from trusted AD domains directly and makes this data available via the NSS responder. With this mode enabled winbind is not needed anymore to lookup users and groups of trusted domains. This patch removed the calls to winbind from the extdom plugin and replaces them with standard POSIX calls like getpwnam() and calls from libsss_nss_idmap to lookup SIDs. Fixes https://fedorahosted.org/freeipa/ticket/3637 because now the extdom plugin does not need to handle idranges anymore, but everything is done inside SSSD.
Diffstat (limited to 'daemons/configure.ac')
-rw-r--r--daemons/configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/daemons/configure.ac b/daemons/configure.ac
index 21d4e7a77..62722d554 100644
--- a/daemons/configure.ac
+++ b/daemons/configure.ac
@@ -240,6 +240,7 @@ dnl -- dirsrv is needed for the extdom unit tests --
PKG_CHECK_MODULES([DIRSRV], [dirsrv >= 1.3.0])
dnl -- sss_idmap is needed by the extdom exop --
PKG_CHECK_MODULES([SSSIDMAP], [sss_idmap])
+PKG_CHECK_MODULES([SSSNSSIDMAP], [sss_nss_idmap])
dnl ---------------------------------------------------------------------------
dnl - Check for systemd unit directory