summaryrefslogtreecommitdiffstats
path: root/daemons/configure.ac
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2011-12-12 11:32:06 +0100
committerMartin Kosek <mkosek@redhat.com>2012-06-28 08:13:22 +0200
commitac6afd31f72d95bc23cde2b22a5fec8267147914 (patch)
tree136221ce7bd30bed2c8e6ff133e89945f2c5c8cb /daemons/configure.ac
parentdc3491ea422112819edacc643cd9d2ba1b4cf056 (diff)
downloadfreeipa-ac6afd31f72d95bc23cde2b22a5fec8267147914.tar.gz
freeipa-ac6afd31f72d95bc23cde2b22a5fec8267147914.tar.xz
freeipa-ac6afd31f72d95bc23cde2b22a5fec8267147914.zip
Add configure check for C Unit-Test framework check
The framework can be found at http://check.sourceforge.net.
Diffstat (limited to 'daemons/configure.ac')
-rw-r--r--daemons/configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/daemons/configure.ac b/daemons/configure.ac
index 5dbdca20a..9ee77e471 100644
--- a/daemons/configure.ac
+++ b/daemons/configure.ac
@@ -240,6 +240,16 @@ PKG_CHECK_MODULES([SAMBAUTIL], [samba-util])
SAMBA40EXTRA_LIBPATH="-L`$PKG_CONFIG --variable=libdir samba-util`/samba"
AC_SUBST(SAMBA40EXTRA_LIBPATH)
+dnl ---------------------------------------------------------------------------
+dnl - Check for check unit test framework http://check.sourceforge.net/
+dnl ---------------------------------------------------------------------------
+PKG_CHECK_MODULES([CHECK], [check >= 0.9.5], [have_check=1], [have_check=])
+if test x$have_check = x; then
+ AC_MSG_WARN([Without the 'CHECK' library, you will be unable to run all tests in the 'make check' suite])
+else
+ AC_CHECK_HEADERS([check.h],,AC_MSG_ERROR([Could not find CHECK headers]))
+fi
+AM_CONDITIONAL([HAVE_CHECK], [test x$have_check != x])
dnl ---------------------------------------------------------------------------
dnl - Set the data install directory since we don't use pkgdatadir