summaryrefslogtreecommitdiffstats
path: root/asn1/Makefile.am
diff options
context:
space:
mode:
authorSimo Sorce <simo@redhat.com>2014-11-13 11:31:09 -0500
committerSimo Sorce <simo@redhat.com>2014-11-20 10:52:13 -0500
commitc6afc489a1c9d86fd593bd47c4a8dae6d9a008d2 (patch)
tree27ad9cc99e3c8e38b8df1adacb3cca5e3f8f1e43 /asn1/Makefile.am
parentb170851058d6712442d553ef3d11ecd21b282443 (diff)
downloadfreeipa-c6afc489a1c9d86fd593bd47c4a8dae6d9a008d2.tar.gz
freeipa-c6afc489a1c9d86fd593bd47c4a8dae6d9a008d2.tar.xz
freeipa-c6afc489a1c9d86fd593bd47c4a8dae6d9a008d2.zip
Add asn1c generated code for keytab controls
Instead of manually encoding controls, use an actual asn1 compiler. The file asn1/asn1c/ipa.asn1 will contain ipa modules. The generated code is committed to the tree and built into a static library that is linked to the code that uses it. The first module implements the GetKeytabControl control. Related: https://fedorahosted.org/freeipa/ticket/4718 https://fedorahosted.org/freeipa/ticket/4728 Reviewed-By: Alexander Bokovoy <abokovoy@redhat.com> Reviewed-By: Nathaniel McCallum <npmccallum@redhat.com>
Diffstat (limited to 'asn1/Makefile.am')
-rw-r--r--asn1/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/asn1/Makefile.am b/asn1/Makefile.am
new file mode 100644
index 000000000..03e92b2d6
--- /dev/null
+++ b/asn1/Makefile.am
@@ -0,0 +1,8 @@
+SUBDIRS = asn1c
+
+AM_CPPFLAGS = -I../util -Iasn1c
+
+noinst_LTLIBRARIES=libipaasn1.la
+noinst_HEADERS=ipa_asn1.h
+libipaasn1_la_SOURCES=ipa_asn1.c
+libipaasn1_la_LIBADD=asn1c/libasn1c.la