summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py29
1 files changed, 29 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..2f1a99c
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,29 @@
+import os
+from setuptools import setup
+
+# Utility function to read the README file.
+# Used for the long_description. It's nice, because now 1) we have a top level
+# README file and 2) it's easier to type in the README file than to put a raw
+# string in below ...
+def read(fname):
+ return open(os.path.join(os.path.dirname(__file__), fname)).read()
+
+setup(
+ name = "di",
+ version = "0.1",
+ author = "Martin Sivak",
+ author_email = "msivak@redhat.com",
+ description = ("Python module which provides decorators to make "
+ "dependency injection easy to use."),
+ license = "GPLv2+",
+ keywords = "testing dependency injection IoC",
+ url = "http://fedorapeople.org/cgit/msivak/public_git/python-di.git/",
+ packages = ['di'],
+ long_description=read('README'),
+ classifiers=[
+ "Development Status :: 3 - Alpha",
+ "Intended Audience :: Developers",
+ "Topic :: Software Development :: Testing",
+ "License :: OSI Approved :: GNU General Public License v2 or later (GPLv2+)",
+ ],
+)