summaryrefslogtreecommitdiffstats
path: root/python-di.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-di.spec')
-rw-r--r--python-di.spec41
1 files changed, 41 insertions, 0 deletions
diff --git a/python-di.spec b/python-di.spec
new file mode 100644
index 0000000..9efd750
--- /dev/null
+++ b/python-di.spec
@@ -0,0 +1,41 @@
+%if 0%{?rhel} && 0%{?rhel} <= 5
+%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
+%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
+%endif
+
+Name: python-di
+Version: 0.1
+Release: 1%{?dist}
+Summary: Python library for dependency injection support
+
+License: GPLv2+
+URL: http://fedorapeople.org/cgit/msivak/public_git/python-di.git/
+Source0: python-di-%{version}-%{release}.tar.gz
+
+#BuildRequires:
+#Requires:
+
+%description
+This python package provides a "di" module. That module contains couple of
+decorators which try to implement Dependency Injection pattern without
+requiring the user to change local variables in his methods.
+
+It is intended to be used in unit testing environments.
+
+%prep
+%setup -q
+
+%build
+%{__python} setup.py make
+
+%install
+%{__python} setup.py install
+
+%files
+%{python_sitelib}/di
+
+%doc
+
+
+
+%changelog