summaryrefslogtreecommitdiffstats
path: root/mod_lookup_identity.spec
diff options
context:
space:
mode:
Diffstat (limited to 'mod_lookup_identity.spec')
-rw-r--r--mod_lookup_identity.spec31
1 files changed, 17 insertions, 14 deletions
diff --git a/mod_lookup_identity.spec b/mod_lookup_identity.spec
index 29c6a8e..881da4a 100644
--- a/mod_lookup_identity.spec
+++ b/mod_lookup_identity.spec
@@ -1,12 +1,13 @@
+%{!?_httpd_mmn: %{expand: %%global _httpd_mmn %%(cat %{_includedir}/httpd/.mmn || echo 0-0)}}
%{!?_httpd_apxs: %{expand: %%global _httpd_apxs %%{_sbindir}/apxs}}
%{!?_httpd_confdir: %{expand: %%global _httpd_confdir %%{_sysconfdir}/httpd/conf.d}}
# /etc/httpd/conf.d with httpd < 2.4 and defined as /etc/httpd/conf.modules.d with httpd >= 2.4
%{!?_httpd_modconfdir: %{expand: %%global _httpd_modconfdir %%{_sysconfdir}/httpd/conf.d}}
%{!?_httpd_moddir: %{expand: %%global _httpd_moddir %%{_libdir}/httpd/modules}}
-Summary: Apache module to retrieve additional information about the authenticated user.
+Summary: Apache module to retrieve additional information about the authenticated user
Name: mod_lookup_identity
-Version: 0.8.1
+Version: 0.8.2
Release: 1%{?dist}
License: ASL 2.0
Group: System Environment/Daemons
@@ -16,7 +17,7 @@ BuildRequires: httpd-devel
BuildRequires: dbus-devel
BuildRequires: pkgconfig
Requires(pre): httpd
-Requires: httpd
+Requires: httpd-mmn = %{_httpd_mmn}
Requires: dbus-libs
# Suppres auto-provides for module DSO
@@ -24,9 +25,8 @@ Requires: dbus-libs
%{?filter_setup}
%description
-mod_lookup_identity can retrieve GECOS and group information about
-user authenticated in Apache httpd server, as well as attributes
-about the user provided by local sssd, and store these values
+mod_lookup_identity can retrieve additional pieces of information
+about user authenticated in Apache httpd server and store these values
in notes/environment variables to be consumed by web applications.
Use of REMOTE_USER_* environment variables is recommended.
@@ -34,7 +34,7 @@ Use of REMOTE_USER_* environment variables is recommended.
%setup -q -n %{name}-%{version}
%build
-%{_httpd_apxs} -c $(pkg-config --cflags dbus-1) mod_lookup_identity.c $(pkg-config --libs dbus-1) -Wall -pedantic
+%{_httpd_apxs} -c -Wc,"%{optflags} -Wall -pedantic $(pkg-config --cflags dbus-1)" $(pkg-config --libs dbus-1) mod_lookup_identity.c
%install
rm -rf $RPM_BUILD_ROOT
@@ -51,28 +51,31 @@ install -Dp -m 0644 lookup_identity.conf $RPM_BUILD_ROOT%{_httpd_confdir}/lookup
%files
%doc README LICENSE
%if "%{_httpd_modconfdir}" != "%{_httpd_confdir}"
-%config(noreplace) %{_httpd_modconfdir}/*.conf
+%config(noreplace) %{_httpd_modconfdir}/55-lookup_identity.conf
%else
%config(noreplace) %{_httpd_confdir}/lookup_identity.conf
%endif
%{_httpd_moddir}/*.so
%changelog
-* Fri Jan 17 2014 Jan Pazdziora - 0.8.1-1
+* Thu Jan 30 2014 Jan Pazdziora <jpazdziora@redhat.com> - 0.8.2-1
+- 1058812 - .spec changes for Fedora package review.
+
+* Fri Jan 17 2014 Jan Pazdziora <jpazdziora@redhat.com> - 0.8.1-1
- Ensure we run before mod_headers so that our result can be put to
request headers for mod_proxy.
-* Thu Jan 09 2014 Jan Pazdziora - 0.8-1
+* Thu Jan 09 2014 Jan Pazdziora <jpazdziora@redhat.com> - 0.8-1
- Declare all functions static for proper isolation.
-* Thu Nov 21 2013 Jan Pazdziora - 0.7.1-1
+* Thu Nov 21 2013 Jan Pazdziora <jpazdziora@redhat.com> - 0.7.1-1
- Address segfault when no LookupUserAttrIter is set.
-* Tue Nov 19 2013 Jan Pazdziora - 0.7-1
+* Tue Nov 19 2013 Jan Pazdziora <jpazdziora@redhat.com> - 0.7-1
- Define lookup_identity_hook as optional function, callable from
other modules.
-* Mon Nov 18 2013 Jan Pazdziora - 0.6-1
+* Mon Nov 18 2013 Jan Pazdziora <jpazdziora@redhat.com> - 0.6-1
- Use org.freedesktop.sssd.infopipe.GetUserGroups for group lists.
- Support new org.freedesktop.sssd.infopipe.GetUserAttr parameters /
return values.
@@ -82,5 +85,5 @@ install -Dp -m 0644 lookup_identity.conf $RPM_BUILD_ROOT%{_httpd_confdir}/lookup
- Added LookupUserGroupsIter and LookupUserAttrIter.
- Added LookupDbusTimeout.
-* Mon Oct 28 2013 Jan Pazdziora - 0.5-1
+* Mon Oct 28 2013 Jan Pazdziora <jpazdziora@redhat.com> - 0.5-1
- Initial release.