summaryrefslogtreecommitdiffstats
path: root/src
Commit message (Collapse)AuthorAgeFilesLines
...
* Fixed @kill killing yourselfErik Schilling2013-04-101-1/+1
|
* Fixed undefined #defines in mingw and c++0xErik Schilling2013-04-072-0/+7
| | | | | It looks like mingw does not define all the stuff in c++0x it does without.
* Moved the Monster class to a ComponentErik Schilling2013-04-0314-123/+160
| | | | | | | Things done: - Allowed to create new Attributes outside of the protected scope of Being - Moved Monster to MonsterComponent - Some minor cleanup in the Attribute setting code of monsters
* Fixed multiple warnings and errors that blocked c++0xErik Schilling2013-04-0218-53/+74
| | | | | This allows the server to compile with c++0x (and enables it). This also includes some coding style / readabillity fixes.
* Removed old commandhandler approachErik Schilling2013-04-022-440/+0
| | | | It was forgotten to remove when the new approach was added
* Moved fighting code into a componentErik Schilling2013-04-0222-374/+647
| | | | | | | | | | | | | | | | | | | | | | | | | All damage dealing is now handeled via CombatComponent. Monsters use a derived MonsterCombatComponent since they can have a damage mutation and have a seperate script callback. The wirering with Being is still not optional since most of the stuff does not exist as components. Things done: - Seperated the fighting code from Being and only let Characters and Monsters add the Component (less overhead for npcs) - Added a getter for Attribute values to prevent searching it all the time in non Being members - Fixed the type if the damage mutation to double (no idea why it was int) I did not want to copy it over incorrectly - Removed the addAttack/removeAttack overrides in Character and made the knuckleAttack being added based on newly added signals Future TODOS: - Remove depedency on Being as soon all needed dependencies are available as components of Entity - Move the monster script callback into the general combatcomponent and make it usuable for characters too
* Moved documentation out of class definitionThorbjørn Lindeijer2013-03-252-68/+97
| | | | | | | | | | | | | | | Inline documentation is in general needlessly verbose and only makes it harder to read the actual class API. This change moves this kind of documentation to the function implementation for the 'Entity' class. For inline methods, the implementation is moved outside of the class using the 'inline' keyword. This provides a good place to put the documentation, but it also further cleans up the class definition. The class definition now gives a much better overview over its API. And if needed, details can be looked up at the function implementations. Reviewed-by: Erik Schilling
* Changed NPC to an NpcComponent added to a BeingThorbjørn Lindeijer2013-03-2514-172/+178
|
* Changed Effect to a component of ActorThorbjørn Lindeijer2013-03-259-53/+61
| | | | Reviewed-by: Yohann Ferreira
* Changed Item to a component of ActorThorbjørn Lindeijer2013-03-2515-84/+129
| | | | | | | | | | | | | | | Items also have positions, so the ItemComponent only makes sense as part of an Actor. Later on it will probably be part of an entity that also has an ActorComponent. Since it was annoying to update all the places where items were created, I've introduced a function for this. The component types are now prefixed with "CT_" because I wanted to introduce an 'Item' namespace which would otherwise be conflicting. The component types enum isn't used much in the code so it can look a bit ugly. Reviewed-by: Yohann Ferreira
* Changed SpawnArea and TriggerArea to components of EntityThorbjørn Lindeijer2013-03-2512-61/+198
| | | | | | Well, first visible change is that everything just gets longer to read. Reviewed-by: Yohann Ferreira
* Removed mentioning of retired structThorbjørn Lindeijer2013-02-241-2/+0
| | | | MonsterTargetEventDispatch was used before switching to libsigc++.
* Added Debug class for more convenient debugging outputThorbjørn Lindeijer2013-02-241-0/+34
| | | | | Inspired by the QDebug class and qDebug() function from Qt. Actually it might be nice if the LOG macro would also use this.
* Fixed default value of the servernameErik Schilling2013-02-242-2/+3
| | | | | Since the name was used to log things and the default now is "" also added logging of the address and port too.
* Added possibility to reserve mapsErik Schilling2013-02-248-31/+139
| | | | | | | | | | | | If you set net_gameServerName you can now reserve maps in the maps.xml. There you have to add the servername - property to the <map> tag. Then the map will only be activated by that server. Also changed the activate sequence that the account server now tells the game server what maps to activate (previously the server requested all maps and the account server said yes or no). TODO: Fix general inter server map switching.
* Made the scripts being able to installErik Schilling2013-02-241-3/+7
| | | | | | | The game server will now look for the scripts in this order: - serverPath - config value - current working directory - the PKG_DATADIR #define
* Documented all lua binds directly in the sourceErik Schilling2013-02-241-1341/+2201
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | This change adds a comment to each lua binding. In the future a script should parse those and generate the docs from them. This should prevent outdated docs and duplicate effort to keep code and docs synced. In C++ categories can be defined in this way: /** LUA_CATEGORY long description of the category (shortname) * further text * goes into * the next lines */ The shortname is only used to bind other comments to the category. In lua the category would look like this: --- LUA_CATEGORY long description of the category (shortname) -- further text -- goes into -- the next lines A comment that describes a bind then can look like this: /** LUA some_function (shortnameofcategory) * some_function(string name) * some_function(int id) ** * Description */ Or in Lua: --- LUA some_function (shortnameofcategory) -- some_function(string name) -- some_function(int id) --- -- Description Autoupdates script follows soon
* Removed loading of script files using the statusmanagerErik Schilling2013-02-211-17/+1
| | | | | They are now required via the main.lua. Also made Harmony giving you the plague in order to allow testing.
* Introduced Script::ContextErik Schilling2013-02-2116-87/+99
| | | | | | | | This should allow to finally call functions to lua without having to care about working around situations where a lua call causes a c++ call which needs to call to lua again. Tested against the source of tales repository data.
* Monsters no longer load their script filesErik Schilling2013-02-173-40/+0
| | | | | | | | | | | Before monsters loaded their script file on *each* spawn. This is rather wrong since the script state keeps growing for each monster. However all of this was unnessecary since the main.lua can simply require the script file. If you do not want to spam the main.lua (or any other file) with all the requires: I guess we can add script binds to iterate over all monsters and add some custom properties to the monsters.xml (See Mana-Mantis #356)
* Moved attribute (re)calculation to the scriptsErik Schilling2013-02-047-176/+96
| | | | | | | | | | | | | | | | | | | | | | This introduces two callbacks: - on_update_derived_attribute -> Called to recalculate other derived attributes. - on_recalculate_base_attribute -> Called to recalculate a base attribute (only called for characters. However the function passed as callback can be useful for recalculating the derived attributes as well) Monsters no longer block recalculation of attributes except HP and Speed. I saw no sense to keep this. Fixed constant value in libmana-constants.lua Dropped bool type of the recalculation functions. It would be difficult to keep it while pushing all to the script engine and it was unused anyway. All in all this adds a LOT more flexibillity to projects since they can now adapt all attributes in the way they want.
* Random cleanup of attribute codeErik Schilling2013-02-043-19/+28
| | | | Did this during trying to understand the code
* Modifications to allow crosscompiling with mingwErik Schilling2013-02-037-4/+23
| | | | Reviewed-by: bjorn.
* Silenced to Wreorder warnings.Yohann Ferreira2013-02-012-3/+3
|
* Added emote support.Yohann Ferreira2013-02-0111-2/+196
|
* Silenced some eclipse warningsErik Schilling2013-01-298-5/+21
|
* Fixed setting current map for npc update functionErik Schilling2013-01-151-0/+2
|
* Small simplification in Monster::diedThorbjørn Lindeijer2013-01-101-4/+4
|
* Used a typedef to make callback syntax more readableThorbjørn Lindeijer2013-01-101-11/+8
|
* Small documentation updates for Point and RectangleThorbjørn Lindeijer2013-01-102-4/+3
| | | | | | | This documentation used to be accurate, until Point was merged with the Position class in commit 8ff3e6674c1d4fc05fc1ba87f42484689fca0879. Also fixed a typo.
* Removed deprecated and unused Storage::flushSkillThorbjørn Lindeijer2013-01-102-19/+0
|
* Made sure in-inventory trigger is called at pickupErik Schilling2013-01-101-1/+9
| | | | | | Also added checks for invalid item and zero amount Reviewed-by: bjorn.
* Removed unused functor obj_name_isThorbjørn Lindeijer2013-01-091-20/+0
|
* Replaced EventListener with signals based on libsigc++Thorbjørn Lindeijer2013-01-0919-337/+150
| | | | | | | | | | | | | This replaces the rather hard to understand event dispatcher with a probably even harder to understand templated library, but fortunately we can rely on the available documentation. Hopefully it will also help with the readability of our code and with adding additional signals to other classes. Added libsigc++ to README and Travis CI configuration. Reviewed-by: Erik Schilling
* Replaced 'unsigned int' with 'unsigned'Thorbjørn Lindeijer2013-01-0955-298/+286
| | | | Same thing, but shorter.
* Micro-optimizations for pushing strings to LuaThorbjørn Lindeijer2013-01-094-37/+29
| | | | | Use lua_pushliteral and lua_pushlstring instead of lua_pushstring, which avoids Lua having to determine the length of the string.
* Added support for Lua 5.2Thorbjørn Lindeijer2013-01-093-1/+23
| | | | Should still work against Lua 5.1 as well.
* Fixed syntax error (added missing '{')Thorbjørn Lindeijer2013-01-081-0/+1
|
* Added Vulnerabilities for monstersErik Schilling2013-01-083-1/+28
| | | | | | | You can now actually use the already used node in the monsters.xml Monsters can have different vulnerabillities against elements: <vulnerabillity element="earth" factor="2.0" /> This will double damage of the element earth to this monster.
* Added script binds for getting attack informationErik Schilling2013-01-082-8/+155
| | | | | | | | | | | | | | | | | | | | | | | | | New binds: - Damage: - id - skill - base - delta - cth - element - type - truestrike - range - Attack: - priority - cooldown - warmup - global_cooldown - damage - on_attack - MonsterClass: - attacks - ItemClass: - attacks
* Work on (Auto)Attack system.Erik Schilling2013-01-0816-474/+617
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | During the implementation bjorn and I agreed to limit the number of attacks that can be used in the same tick to one. This makes a lot of stuff easier and the client cannot display two frames at the same time Things done: - Implemented setting of attacks when equipping/unequipping items - Single place where the xml attack node is parsed - Finished attack logic - Unified the attack handling of monsters and characters - Added a global cooldown after attack use (not only for next use of same attack) - Removed the temponary attributes for the monster attack values - Priorities for all attacks - Rewrote the attack core: - Attacks now have this attributes: - warmup -> time a attack needs after starting it to actually deal the damage - cooldown -> time a attack needs after dealing damage before another attack can be used - reuse -> time before the same attack can be used again - If no attack is performed at the moment the following is done: - make a list with all ready attacks - check for attack that has the necessarily range and highest priority - start this attack (inform client about it) - when warmup is finished -> trigger damage - when cooldown is finished -> allow to use other (or the same if reusetimer allows) attacks TODO: - sync client with this to allow better timed animations
* Rename AutoAttack to AttackErik Schilling2013-01-0810-50/+50
|
* Set the current map when executing being callbacksThorbjørn Lindeijer2013-01-071-0/+2
| | | | | | | | The on_death and on_remove callbacks where not being executed in the context of any map. Now they execute in the context of the map of the being. Reviewed-by: Erik Schilling
* Create database using a single transactionThorbjørn Lindeijer2012-12-151-0/+4
| | | | | Takes the time required to do initial database creation down from 16 to 0.2 seconds on the Raspberry Pi.
* Moved order of sending genderErik Schilling2012-10-112-7/+5
| | | | | | | | | Gender is shared. There is no reason in duplicating code *Breaks compatbility with old clients* *Requires clientside patch* Reviewed-by: Stefan Beller.
* Extended warnings for parsing warpsErik Schilling2012-09-221-1/+1
| | | | Reviewed-by: bjorn.
* Fixed marking map as activatedErik Schilling2012-09-222-19/+40
| | | | | | | | The patch that allowed to use map objects as warp targets broke this. During run of map initalize mActive was still false. This broke creating objects (npc, triggers) in atinit. Reviewed-by: bjorn.
* Allow map objects as warp targetsErik Schilling2012-09-023-14/+57
| | | | | | | | | | | | | | | | This patch allows map objects as warp targets. For use: - Create object in tiled with type="WARP_DEST" - Set name to anything you want - Create usual WARP object - Leave out the DEST_{X,Y} part - Add DEST_NAME property with the name of the first object This requires the game server to parse all maps at startup. Change is tested. Reviewed-by: bjorn.
* Dropped .gz suffix for mapsErik Schilling2012-09-021-2/+0
| | | | Reviewed-by: bjorn.
* Fixed item_drop insertion of objectErik Schilling2012-08-101-3/+2
|