summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorThorbjørn Lindeijer <thorbjorn@lindeijer.nl>2010-05-13 13:39:52 +0200
committerThorbjørn Lindeijer <thorbjorn@lindeijer.nl>2010-05-16 23:25:19 +0200
commite5c7ef4573adcdcafec7523a77724b171456b215 (patch)
tree797833ddc766d92131da86096de81741a94f4d20 /src/CMakeLists.txt
parent0a48f0d41653d0a0758fc84fd6a18830bd37da18 (diff)
downloadmanaserv-e5c7ef4573adcdcafec7523a77724b171456b215.tar.gz
manaserv-e5c7ef4573adcdcafec7523a77724b171456b215.tar.xz
manaserv-e5c7ef4573adcdcafec7523a77724b171456b215.zip
Changed and split up the default location for loading data
Instead of loading data from a 'data' directory in the current working directory, the server now uses clientDataPath and serverDataPath as specified in the configuration. This removes the need to set up symbolic links in order to merge these two types of data. The default values point to example/clientdata and example/serverdata, where a minimal example world can be developed to make setting up an initial server quick and easy. The XML::Document convenience class was copied over from the client. Also, the ResourceManager is now shared between both servers, since the account client is reading items.xml. Reviewed-by: Jared Adams
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 48aaf3a..69393de 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -103,6 +103,8 @@ SET(SRCS
common/configuration.hpp
common/configuration.cpp
common/inventorydata.hpp
+ common/resourcemanager.hpp
+ common/resourcemanager.cpp
net/bandwidth.hpp
net/bandwidth.cpp
net/connection.hpp
@@ -120,6 +122,8 @@ SET(SRCS
utils/logger.cpp
utils/processorutils.hpp
utils/processorutils.cpp
+ utils/string.hpp
+ utils/string.cpp
utils/stringfilter.h
utils/stringfilter.cpp
utils/timer.h
@@ -130,7 +134,6 @@ SET(SRCS
utils/tokendispenser.cpp
utils/xml.hpp
utils/xml.cpp
- utils/string.cpp
)
SET(SRCS_MANASERVACCOUNT
@@ -225,8 +228,6 @@ SET(SRCS_MANASERVGAME
game-server/postman.hpp
game-server/quest.hpp
game-server/quest.cpp
- game-server/resourcemanager.hpp
- game-server/resourcemanager.cpp
game-server/skillmanager.hpp
game-server/skillmanager.cpp
game-server/spawnarea.hpp