summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorErik Schilling <ablu.erikschilling@googlemail.com>2011-12-02 23:53:45 +0100
committerErik Schilling <ablu.erikschilling@googlemail.com>2013-02-24 20:44:13 +0100
commitdd20c7f6148cc8b8b627028e25e817cc1cab063b (patch)
treeb7c9900c8b01aa67a496cd92276a166450817761 /src/CMakeLists.txt
parent9860dacbb6526138ae8edf57adc42ddc3e6073fa (diff)
downloadmanaserv-dd20c7f6148cc8b8b627028e25e817cc1cab063b.tar.gz
manaserv-dd20c7f6148cc8b8b627028e25e817cc1cab063b.tar.xz
manaserv-dd20c7f6148cc8b8b627028e25e817cc1cab063b.zip
Added possibility to reserve maps
If you set net_gameServerName you can now reserve maps in the maps.xml. There you have to add the servername - property to the <map> tag. Then the map will only be activated by that server. Also changed the activate sequence that the account server now tells the game server what maps to activate (previously the server requested all maps and the account server said yes or no). TODO: Fix general inter server map switching.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index c8752fb..629df5e 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -153,6 +153,8 @@ SET(SRCS_MANASERVACCOUNT
account-server/character.h
account-server/character.cpp
account-server/flooritem.h
+ account-server/mapmanager.h
+ account-server/mapmanager.cpp
account-server/serverhandler.h
account-server/serverhandler.cpp
account-server/storage.h