summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorBernd Wachter <bwachter-mana@lart.info>2010-01-29 23:11:12 +0100
committerThorbjørn Lindeijer <thorbjorn@lindeijer.nl>2010-01-30 10:38:30 +0100
commitab6692f88932efb60292ce4ac5c7f3eb152402cd (patch)
treee7d9a9e32e698d96873751f8fa6e709eecc50238 /src/CMakeLists.txt
parent37a76ca927a308aaad718fa937132696e9f081fd (diff)
downloadmanaserv-ab6692f88932efb60292ce4ac5c7f3eb152402cd.tar.gz
manaserv-ab6692f88932efb60292ce4ac5c7f3eb152402cd.tar.xz
manaserv-ab6692f88932efb60292ce4ac5c7f3eb152402cd.zip
Win32 build fixes when building with cmake
Add missing zlib dependency, add NOGDI flag to avoid namespace clashes.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 2954242..48aaf3a 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -74,8 +74,12 @@ IF (CMAKE_BUILD_TYPE)
ENDIF()
IF (WIN32)
- SET(EXTRA_LIBRARIES ws2_32 winmm)
- #FIND_PACKAGE(LibIntl REQUIRED)
+ # on the client zlib gets pulled in by LibPNG, for the server
+ # we need to add it explicitly
+ FIND_PACKAGE(ZLIB REQUIRED)
+ SET(EXTRA_LIBRARIES ws2_32 winmm ${ZLIB_LIBRARIES})
+ # GDI APIs Rectangle clashes with tmwserv classes
+ SET(FLAGS "${FLAGS} -DNOGDI")
ELSEIF (CMAKE_SYSTEM_NAME STREQUAL SunOS)
# explicit linking to libintl is required on Solaris
SET(EXTRA_LIBRARIES intl)