summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorErik Schilling <ablu.erikschilling@googlemail.com>2013-04-02 22:25:24 +0200
committerErik Schilling <ablu.erikschilling@googlemail.com>2013-04-02 22:28:24 +0200
commit4a8080dcf73dab2b6e62b8500fec3bb996bcbf17 (patch)
tree67ef51dbb1b360f9a3e7c38cf0dbeb2b5f001bfd /src/CMakeLists.txt
parentad3958701136ff8ae4a4fc749ef616cc8917d2af (diff)
downloadmanaserv-4a8080dcf73dab2b6e62b8500fec3bb996bcbf17.tar.gz
manaserv-4a8080dcf73dab2b6e62b8500fec3bb996bcbf17.tar.xz
manaserv-4a8080dcf73dab2b6e62b8500fec3bb996bcbf17.zip
Fixed multiple warnings and errors that blocked c++0x
This allows the server to compile with c++0x (and enables it). This also includes some coding style / readabillity fixes.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 8c88d71..85d6b6d 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -41,6 +41,8 @@ SET(FLAGS "${FLAGS} -DPACKAGE_VERSION=\\\"${VERSION}\\\"")
SET(FLAGS "${FLAGS} -DPKG_DATADIR=\\\"${PKG_DATADIR}/\\\"")
SET(FLAGS "${FLAGS} -DLOCALEDIR=\\\"${LOCALEDIR}/\\\"")
+SET(FLAGS "${FLAGS} -std=c++0x")
+
# If the Sqlite option is enabled...
IF (WITH_SQLITE)
FIND_PACKAGE(Sqlite3 REQUIRED)