summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBertram <bertram@cegetel.net>2010-01-29 00:14:29 +0100
committerBertram <bertram@cegetel.net>2010-01-29 00:14:29 +0100
commit9b6377b7d34805535b810a54c5b09c3fd23b3ca8 (patch)
treecaab37efa17d72d1205e929a9886070edeb356cb /CMakeLists.txt
parentf7f0f36c3fec7786e15ee79c7aa184c50caa3cd7 (diff)
downloadmanaserv-9b6377b7d34805535b810a54c5b09c3fd23b3ca8.tar.gz
manaserv-9b6377b7d34805535b810a54c5b09c3fd23b3ca8.tar.xz
manaserv-9b6377b7d34805535b810a54c5b09c3fd23b3ca8.zip
Upgraded CMakeLists.txt files to deal with compile option. I have still one problem with Lua...
There must be something wrong in the FindLua.cmake module because the FIND_PACKAGE(Lua) doesn't work and is currently commented out.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt21
1 files changed, 20 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d365b8a..8bc69a7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,6 +9,26 @@ ENDIF()
# where to look for cmake modules
SET(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/CMake/Modules)
+OPTION(WITH_SQLITE "Enable Sqlite support (used by default)" ON)
+OPTION(WITH_MYSQL "Enable building of tranlations" OFF)
+OPTION(ENABLE_LUA "Enable Lua scripting support" OFF)
+
+# Exclude Sqlite support if the MySQL support was asked.
+IF(WITH_MYSQL)
+ SET(WITH_SQLITE OFF)
+ SET(WITH_POSTGRESQL OFF)
+ENDIF()
+
+IF(WITH_POSTGRESQL)
+ SET(WITH_SQLITE OFF)
+ SET(WITH_MYSQL OFF)
+ENDIF()
+
+IF(WITH_SQLITE)
+ SET(WITH_MYSQL OFF)
+ SET(WITH_POSTGRESQL OFF)
+ENDIF()
+
IF (WIN32)
SET(PKG_DATADIR ".")
SET(PKG_BINDIR ".")
@@ -31,4 +51,3 @@ ELSE (WIN32)
ENDIF (WIN32)
ADD_SUBDIRECTORY(src)
-